Linux žaliems: openSUSE/Juodas ekranas arba konsolė paleidžiant iš diegimo laikmenos: Skirtumas tarp puslapio versijų

 
 
=== Diekite nuosavybines tvarkykles ===
Nuosavybinės tvarkyklės paprastai prieinamos vidutinio senumo ir naujoms NVIDIA ir AMD vaizdo plokštėms. Nors senoms NVIDIA ir AMD/ATI vaizdo plokštėms neberasite nuosavybinių tvarkyklių, Linukso branduolys jas turėtų gerai palaikyti nediegiant nieko papildomai. Intel pati kuria atviro kodo tvarkykles savo vaizdo plokštėms, tad jos iš karto įtraukiamos į Linukso branduolį.
Jums pravers interneto ryšys. Pridėkite saugyklas priklausomai nuo turimos vaizdo plokštės ir operacinės sistemos versijos, pvz.:
;* NVIDIA:
zypper ar --no-check --refresh ftp://download.nvidia.com/opensuse/13.2/ "Nvidia"
;* AMD/ATI (HD 5*** ir naujesnėms):
zypper ar --no-check --refresh http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2 "AMD ATI"
 
Nuosavybines vaizdo plokščių tvarkykles rekomenduojama diegti RPM paketų pavidalu. Prieš tai reikia pridėti saugyklas priklausomai nuo turimos vaizdo plokštės ir operacinės sistemos versijos. Jums pravers interneto ryšys.
Jei naudojate '''Nvidia''' vaizdo plokštę, patikrinkite kurio paketo jums reikia – x11-video-nvidiaG02, x11-video-nvidiaG03 ar x11-video-nvidiaG04 įvykdydami
;*==== NVIDIA: ====
Pridėti NVIADIA saugyklą galite per arba YaST grafinėje sąsajoje ar ncurses aplinkoje, arba komandinėje eilutėje.
===== Per YaST =====
# Paleiskite YaST valdymo centrą
# Įeikite į ''Saugyklos'' (''Software Repositories'')
# Pasirinkite ''Pridėti'' (''Add'')
# Pasirinkite ''Bendruomenės saugyklos'' (''Community repositories'')
# Susiraskite ''NVIDIA''.
# Patvirtinkite pasirinkimą, jei prašo, priimkite siūlomus saugyklos raktus.
 
Reikiamos tvarkyklės turėtų būti automatiškai pasiūlomos įdiegti kitą kartą atvėrus ''Programinės įrangos tvarkytuvę'' (''Software manager'').
 
===== Komandinėje eilutėje =====
Saugyklą galite pridėti komandinėje eilutėje (pasirinkite vieną, pagal operacinę sistemą):
zypper ar --no-check --refresh ftphttp://download.nvidia.com/opensuse/13.2/ "Nvidia:13.2"
zypper ar --no-check --refresh http://download.nvidia.com/opensuse/leap/42.1/ "Nvidia:42.1"
zypper ar --no-check --refresh http://download.nvidia.com/opensuse/leap/42.2/ "Nvidia:42.2"
zypper ar --no-check --refresh http://download.nvidia.com/opensuse/leap/42.3/ "Nvidia:42.3"
 
Šių saugyklų RPM paketų apraše nurodyta, kad jie turėtų būti automatiškai diegiami, jei kompiuteryje yra atitinkama vaizdo plokštė. Norėdami įdiegti tokius rekomenduojamus paketus, įvykdykite:
zypper install-new-recommends
 
Pastebėtina, kad skirtingoms NVIDIA vaizdo plokščių kartoms siūlomi atskiri paketai. Pavyzdžiui, saugyklose openSUSE 13.1, 13.2, Leap 42.1, Leap 42.2, Leap 42.3 versijoms:
* ''x11-video-nvidiaG02'' tinka NVIDIA GeForce 6 (6xxx), GeForce 7 (7xxx) vaizdo plokštėms (pagamintoms maždaug nuo 2004 iki 2007 metų)
* ''x11-video-nvidiaG03'' tinka NVIDIA GeForce 8xxx, 9xxx, 1xx, 2xx, 3xx serijų vaizdo plokštėms (pagamintoms maždaug nuo 2007 iki 2010 metų)
* ''x11-video-nvidiaG04'' tinka NVIDIA GeForce 4xx ir naujesnėms vaizdo plokštėms (pagamintoms maždaug nuo 2010 metų)
 
Sužinoti, kurie paketai ir kurioms vaizdo plokščių serijoms prieinami ar įdiegti konkrečioje sistemoje, galite įvykdę paiešką:
zypper se x11-video-nvidia
Pastarosios komandos rezultato pavyzdys:
| Pavadinimas | Santrauka | Tipas
+---------------------+---------------------------------------------------------+--------
| x11-video-nvidiaG02 | NVIDIA graphics driver for GeForce 6xxx and newer GPUs | paketas
| x11-video-nvidiaG03 | NVIDIA graphics driver for GeForce 8xxx and newer GPUs | paketas
| x11-video-nvidiaG04 | NVIDIA graphics driver for GeForce 400 series and newer | paketas
 
Pavyzdžiui,Jei jei turite ''NVIDIA GeForce 8***'' arba naujesnęreikia, tai jums reikia ''x11-video-nvidiaG03''.paketus Paketusgalite diekitediegti su ''zypper'', pavyzdžiui taip:
zypper in x11-video-nvidiaG03
 
==== AMD / ATI ====
Jei turite '''AMD/ATI''' vaizdo plokštę, įdiekite '''fglrx*''' paketus. Pastaba: openSUSE 13.2 sistemoje pastarieji tinka Radeon HD 5000 ir naujesnių serijų plokštėms (netinka senesnėms).
[http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx AMDGPU-PRO] tvarkyklės gali būti naudojamos su openSUSE Leap 42.2 ir naujesnėmis versijomis (išskyrus openSUSE Tumbleweed). Šiuo metu tvarkyklės neprieinamos saugyklų pavidalu, tačiau iš AMD svetainės galite parsiųsti archyvą su RPM paketais.
 
Paketų saugyklos su '''AMD FGLRX''' / ''AMD Catalyst / [http://support.amd.com/en-us/download/desktop?os=Linux+x86_64 AMD Radeon Software Crimson Edition] '' tvarkyklėmis prieinamos tik openSUSE Leap 42.1 ir senesnėms versijoms. AMD nuo 2015 metų pabaigos nepalaiko / nebeatnaujina šių tvarkyklių. Paskiausiose openSUSE 13.1, 13.2 ir Leap 42.1 versijose šios tvarkyklės tinka tik AMD/ATI HD 5*** ir naujesnėms vaizdo plokštėms (pagamintoms maždaug 2009–2015 metais):
zypper ar --no-check --refresh http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1 "AMD:13.1"
zypper ar --no-check --refresh http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2 "AMD ATI:13.2"
zypper ar --no-check --refresh http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Leap_42.1/ "AMD:42.1"
 
Alternatyva ''zypper'' programai diegiant paketus – YaST paketų tvarkytuvė, veikianti ir konsolėje.
</gallery>
 
Nors paketus galite diegti ir būdami grafinėje sąsajoje, bet tam, kad juos sistema naudotų, grafinį serverį vis tiek reikia paleisti iš naujo (jei sistema jau pasiekė grafinę stadiją, tai iš jos reikia prieš tai išeiti).
 
== Grafinės sąsajos paleidimas ==
Anoniminis naudotojas